NetCloud Manager Performance Degradation

Incident Report for NetCloud eu4 Instance

Resolved

This incident has been resolved.
Posted May 27, 2026 - 21:32 CEST

Investigating

NetCloud Manager is currently experiencing performance degradation with Remote Connect. Our engineering team is looking into the issue and we expect it to be resolved quickly.
Posted May 27, 2026 - 20:48 CEST
This incident affected: NetCloud Manager Cloud Services - Europe eu4 (Endpoint Management).